Ta strona używa ciasteczek (plików cookies), dzięki którym może działać lepiej. Dowiedz się więcejRozumiem i akceptuję
f3dfilament.com

Arduino + nRF24L01 wysyła złe sygnały

Autor Wiadomość
Neeeds 



Posty: 10
Wysłany: 19-03-2017, 15:10   Arduino + nRF24L01 wysyła złe sygnały

Witam, mam problem z układem łączącym 2 arduina modułami nRF24L01. Mam prosty program sterujący zapalaniem i zgaszaniem diody lecz działa następująco: program jest wgrany w obu arduinach, dioda powinna byc zgaszona ale mruga nierownomiernie, gdy wcisne przycisk to dioda stabilnie sie zapala i swieci gdy trzymam przycisk. Port szeregowy pokazuje że odbiornik otrzymuje informacje (111) po 10 ileś razy pod rząd i około tyle samo (No radio available). Gdy odepne kabelek od przycisku (odstrony Arduino) to normalnie nie wysyła ale gdy odepne od strony przycisku to znowu dioda miga, ten kabelek działa jak antena zbierająca sygnał ale nie mam pojęcia jak to możliwe. Przykład wziąłem stąd:

https://forum.arduino.cc/index.php?topic=138663.0
Polecany artykuł z FORBOT.PL:
Kurs Cadsoft Eagle - część 2 (PCB)

Przedstawiam drugą część kursu obsługi Cadsoft Eagle. Cały znajdujący się tutaj materiał, został poświęcony pr... Czytaj całość

Polecany artykuł » 3D Boom - drukarki Builder 3D w Polsce - KONKURS


Postaw piwo autorowi tego posta
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Wersja do druku

Skocz do:  

Nie rozwiązałeś swojego problemu? Zobacz podobne tematy: Arduino - dziwne zac... Arduino i programowa... Atmega - problem z b... Arduino, problem z o...
lub przeszukaj forum po wybranych tagach: arduino, nrf24l01, sygnaly, wysyla, zle


Powered by phpBB modified by Przemo © 2003 phpBB Group
Popularne kursy: Arduinopodstawy elektroniki